Understanding Bridging on a Router (BVI, CRB, IRB)

For bridging configuration on asr903 visit this post

In an attempt to understand Bridging concepts and the reason why they were introduced on Routers, I have read through multiple articles to help us with it.  This feature helps us “bundle” one or more physical L2 link it to a L3 logical interface(BDI/BVI) for routing.
bundle
As routers do not support configuration of IP addresses belonging to the same L2 subnet/domain on more than one routed interfaces, Bridged interfaces on router serve as a workaround to overcome that limitation.  Features such as EVC (Ethernet Virtual Circuits) were introduced to overcome the scaling limitations of traditional switches to address modern provider and cloud environments. BDIs are more service provider oriented constructs related to VPLS and are the way to implement a layer 2 domain on a router.

Bridging concepts on IOS Vs  IOS-XE

Bridging implementation and configuration differs on  Routers running on IOS compared to those running on IOS-XE.  On IOS based routers, we can configure BVIs (Bridge Virtual Interface) where multiple interfaces can be part of a single bridge group bearing IP addresses in the same subnet where as on IOS-XE the same purpose is addressed by BDI (Bridge domain interface) and service instance.

CRB Vs IRB

These are two modes in which you can define bridging on the router.

CRBIRB

CRB (concurrent routing and bridging) was an early effort to provide a combination of bridging and routing of a protocol on IOS routers. Cisco pretty quickly came up with IRB (Integrated Routing and Bridging) which provides a much more flexible solution for combining bridging and routing of a protocol on a route.

excel-yesno

The above behavior was tested in with the following topology:

Capture1.PNG

The above setup has been tested for CRB and IRB individually. Following are the configurations for each of them:

CRB config:

R3 configuration:

bridge crb

bridge 1 protocol ieee

!
 interface FastEthernet1/0
 bridge-group 1 
 ip address 10.0.0.1 255.255.255.0 
 full-duplex 
 no shut

interface FastEthernet1/1
 bridge-group 1 
 ip address 10.0.0.2 255.255.255.0 
 full-duplex 
 no shut
 !
 Router ospf 1
 network 20.0.0.0 0.0.0.255 area 0
 router-id 1.1.1.1

interface FastEthernet2/0 
 ip address 20.0.0.1 255.255.255.0 
 full-duplex
 no shut
 !

**Note: Configuration on the router R4 will be similar wherein the IP addresses and OSPF router ID will change.

R1 configuration: 

interface FastEthernet1/0
 ip address 10.0.0.3 255.255.255.0 
 full-duplex 
 no shut

!

ip route 0.0.0.0 0.0.0.0 fa1/0 

!

**Note: configuration on R2, R5, R6 will be similar to R1

IRB configuration:

R3 configuration: 

bridge irb

bridge 1 protocol ieee

bridge 1 route ip

interface FastEthernet1/0

bridge-group 1

interface FastEthernet1/1

bridge-group 1

!

interface BVI 1

ip address 10.0.0.10 255.255.255.0

!

ip route 30.0.0.0 255.255.255.0 fa2/0

!

**Note: Configuration on the router R4 will be similar wherein the IP addresses and OSPF router ID will change. do not forget to add static route on R4 for 10.0.0.0/24 subnet All other routers will have same configuration as above.

Observations from testing on above setup:

1- In case of CRB enabled on R3 and R4 10.0.0.0/24 subnet cannot ping 20.0.0.0/24 and 30.0.0./24. This is because the ARP generated by 10.0.0.0/24 for 20 and 30 nextwork will be dropped.

2- In case on IRB all subnets are interconnected and reachable provided the routing configuration is in place.

3- In case of CRB, running debug on end router (R1/R2/R5/R6) will show you “encapsulation failure” message which is generally seen if arp resolution fails.

4- If you test first IRB config and then CRB on the same setup, you will be surprised to see that 10.0.0.0/24 network will be able to ping 20 and 30 network as well. This is because the ARP was already resolved by the end router during IRB testing. In this case clear ARP cache and test again – CRB will work as expected i.e. 10.0.0.0/24 network will not be able to reach 20 and 30 network.

we will continue discussing bridging concepts for IOS-XE based platforms in my next post.

Thanks and reaching out to this blog please rate the post and follow the blog for email updates about new posts.

Stay tuned and happy learning.


One thought on “Understanding Bridging on a Router (BVI, CRB, IRB)

  1. I have a Cisco 1117 with LTE / VDSL interfaces . I was wondering if its possible to bridge between the internal interface Et0/3/0 to the Gi0/0/0 interface , allowing me to set the static IP allocated by the service provider on my FW outside interface

Leave a Reply