ASR1000 : VxLAN Unicast mode Configuration and Verification

For the first blog in this series please Visit my Blog on VxLAN Multicast Mode .

In this blog we are going to discuss the configuration and verification steps for VxLAN Unicast mode on Cisco ASR1000 devices. Apart form ASR1000 devices VxLAN is supported in Cisco Nexus and Csr1000v platform.

If you have seen my blog on VxLAN multicast mode configuration then you must have a basic understanding about the underlying transport. So essentially we just need a transport over which our loopback IP addresses from both the VTEPs are  reachable.

VxLAN Cisco ASR1000 unicast mode
VxLAN-Unicast-mode

 

In This example configuration we will use Unicast mode Vxlan to extend Vlan 3 from one side of the network to other side over ISP network.

Following is the configuration :

VTEP1(1.1.1.1) : 
Vxlan udp port 1024
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface nve1
no ip address
member vni 6002
ingress-replication 2.2.2.2
source-interface Loopback1
!
interface gig0/1 -------------> LAN interface
no ip address
negotiation auto
cdp enable
service instance 3 ethernet
encapsulation dot1q 3
rewrite ingress tag pop 1 symmetric
!
bridge-domain 3
member vni 6002
member gig0/1 service-instance 3

VTEP2(2.2.2.2) :
!
Vxlan udp port 1024
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface nve1
no ip address
member vni 6002
ingress-replication 1.1.1.1
!
source-interface Loopback1
!
interface gig0/1------> LAN interface
no ip address
negotiation auto
cdp enable
service instance 3 ethernet
encapsulation dot1q 3
rewrite ingress tag pop 1 symmetric
!
!
bridge-domain 3
member vni 6002
member gig0/1 service-instance 3

That’s it, this is all we need to configure and Vxlan should be up on your devices. Following are few verification commands:

VTEP1#show nve vni
Interface VNI Multicast-group VNI state
nve1      6000     N/A            Up   -------> State is up 

VTEP1#show nve interface nve1 detail
Interface: nve1, State: Admin Up, Oper Up Encapsulation: Vxlan
source-interface: Loopback1 (primary:1.1.1.1 vrf:0)
Pkts In Bytes In Pkts Out Bytes Out
60129 6593586 55067 5303698     ------> Packets getting encapsulated

VTEP1#show nve peers
Interface  Peer-IP    VNI     Peer state
nve1       2.2.2.2   6000      Up

VTEP2#show nve vni
Interface   VNI     Multicast-group    VNI state
nve1        6000       N/A                Up

VTEP2#show nve interface nve1 detail
Interface: nve1, State: Admin Up, Oper Up Encapsulation: Vxlan
source-interface: Loopback1 (primary:2.2.2.2 vrf:0)
Pkts In Bytes In Pkts Out Bytes Out
70408 7921636 44840 3950835

VTEP2#show nve peers
Interface    Peer-IP       VNI     Peer state
nve1          1.1.1.1      6000        Up

 

Following is  a packet capture snip which shows VxLAN encapsulation header. I will cover encapsulation header and detailed VxLAN operation in my upcoming blog.

Wireshark-Vxlan asr1000 Unicast mode Vxlan
Vxlan Header

 

For now, Thank you for visiting my Blog. Please leave your questions and suggestions in comment section. Stay tuned for more.

Stay tuned for more!!


Leave a Reply