Configuring Cisco ISR 1100 router for 4g/3g Cellular communication

 

For ISR1100 router introduction please visit my blog ISR1100 Introduction

Coming to 4g configuration, this is really interesting topic which I wanted to pick for a very long time and thankfully I got newly manufactured and fresh in market router in my hand. This is Cisco ISR1100 router which comes in many variant and is just like the old 800 series routers. Cisco has WLAN model, LTE model, DSL model and normal enterprise router model for this platform.The difference between old 800 routers and this platform is that this is IOS-XE based device with enhanced performance. You can find more details on Cisco website about the model. I will also try to put some introduction blogs for this.

Lets come to the point and configure Our Cisco ISR 1111-4PLTEA router for cellular communication. Before jumping into CLI we need to get a SIM card and an Antenna(no good signal in lab ūüôĀ ) . Router has slots available for two SIM cards on the device. I have inserted Airtel (4G subscriber in India) SIM card in the router . You can see below image with SIM card and the Antenna installed.

 

C1111-4PLTEA SIM and Antenna
C1111-4PLTEA SIM and Antenna

 

Once the above setup is done we need to enable cellular communication through the CLI configurations. Below is step by step configuration.

We need to configure profile with the APN name which is airtelgprs.com in our case. You can get this information from the provider.

C1111-4PL#cellular 0/2/0 lte profile create 1 airtelgprs.com

Now once the cellular profile is activated we can start configuring the cellular interface and NAT etc so that we can have internal hosts in the network to communicate the outside world.

Gig0/0/0 is the interface which connects to my internal network and the cellular0/2/0 is the once bind with SIM slot 0.¬† Check out the configurations below …

!
interface GigabitEthernet0/0/0
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
!
interface Cellular0/2/0
 ip address negotiated
 ip nat outside
 dialer in-band
 dialer idle-timeout 0
 dialer-group 1
 ipv6 enable
 pulse-time 1
!
ip nat inside source list 1 interface Cellular0/2/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/2/0
!
access-list 1 permit any
dialer-list 1 protocol ip permit

If you are familiar with the cellular configuration on the 800 series router you will notice that we do not need to specify the encapsulation(Slip,ppp,hdlc etc ) here.

One this configuration is done DO NOT forget to start the “interesting traffic” for the dialer ACL defined range. Else you would not see the cellular interface negotiating IP address.

C1111-4PL#sh interfaces cellular 0/2/0
Cellular0/2/0 is up, line protocol is up
 Hardware is LTE Adv TSN CAT6 - Multimode LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS
 Internet address is 100.66.58.219/32
 MTU 1500 bytes, BW 50000 Kbit/sec, DLY 20000 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation HDLC, loopback not set 
 Keepalive not supported
 DTR is pulsed for 1 seconds on reset
 Last input never, output 14:32:42, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 9235 packets input, 1563495 bytes, 0 no buffer
 Received 0 broadcasts (0 IP multicasts)
 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 14387 packets output, 896568 bytes, 0 underruns
 0 output errors, 0 collisions, 3 interface resets
 0 unknown protocol drops
 0 output buffer failures, 0 output buffers swapped out
 0 carrier transitions


C1111-4PL#show ip interface brief
Interface               IP-Address      OK?    Method    Status   Protocol
GigabitEthernet0/0/0    10.10.10.1      YES    NVRAM      up       up
Cellular0/2/0           100.66.58.219   YES    IPCP       up       up
<----SNIP------->

Following are few verification commands, you can see I am able to reach to the outside world, ping for 4.2.2.2 is working and the signal strength is also good after putting Antenna to the router. Before that the signal strength was less than -110 dBm and I was getting hardly any ping response.

4G LTE radio signal strength
Signal Strength and Ping

You can see the packet input and output stats for a particular profile with the help of cellular connection command.

Connection-stats
Connection-stats

 

There are many other verification commands but I think above set of details should be enough for you to verify a working Cellular connection.

Thanks and reaching out to this blog please rate the post and follow the blog for email updates about new posts.

Stay tuned and happy learning.

Advertisements

4 thoughts on “Configuring Cisco ISR 1100 router for 4g/3g Cellular communication

  1. CISCO 1921 ISR is not supporting the encapsulation type SLIP.
    It says “only ppp supported”
    I changed IOS as well, but of no use.
    Kindly if anyone can suggest the solution?????
    How can I enable SLIP on CELLULAR INTERFACE…

  2. Hi! I am new to Cisco routers, just did my CCENT and now got my hands on one of these C1111s. But I am having difficulties to get it configured. In essence I just need an inside VLAN88 (192.168.88.0/24) through int GI0/1/0 and an outside WAN connection on portGi0/0/1 – with a 4G failover to mitigate ISP downtime.
    Really nice to have would be a portchannel with a second LAN port GI0/1/1 connected to two uplink ports in my switch.
    I am running Cisco IOS XE Software, Version 16.09.02

    I am not able to ping 8.8.8.8 from a client behind my switch, but the clients do get DHCP addresses. I am able to ping 8.8.8.8 from my WAN interface, so PPP seems to be working…

    Any hint on what I am doing wrong is appreciated…

    #show running
    Building configuration…
    Current configuration : 8789 bytes
    !
    ! Last configuration change at 18:48:15 UTC Sun Feb 16 2020
    !
    version 16.9
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service internal
    service call-home
    platform qfp utilization monitor load 80
    no platform punt-keepalive disable-kernel-core
    !
    hostname Sxxxx-RTR
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    call-home
    ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
    ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
    contact-email-addr xxxlicensing@cisco.com
    profile “CiscoTAC-1”
    active
    destination transport-method http
    no destination transport-method email
    !
    !
    !
    ip name-server 195.xxx.xxx.xxx
    no ip domain lookup
    ip admission watch-list expiry-time 0
    ip dhcp excluded-address 192.168.88.1
    ip dhcp excluded-address 192.168.88.2
    ip dhcp excluded-address 192.168.88.3
    ip dhcp excluded-address 192.168.88.4
    ip dhcp excluded-address 192.168.88.5
    ip dhcp excluded-address 192.168.88.6
    ip dhcp excluded-address 192.168.88.7
    ip dhcp excluded-address 192.168.88.8
    ip dhcp excluded-address 192.168.88.9
    ip dhcp excluded-address 192.168.88.10
    ip dhcp excluded-address 192.168.88.247
    ip dhcp excluded-address 192.168.88.248
    ip dhcp excluded-address 192.168.88.249
    ip dhcp excluded-address 192.168.88.250
    ip dhcp excluded-address 192.168.88.254
    ip dhcp excluded-address 192.168.88.253
    ip dhcp excluded-address 192.168.88.252
    ip dhcp excluded-address 192.168.88.251
    ip dhcp excluded-address 192.168.88.0
    ip dhcp excluded-address 192.168.88.255 255.255.255.255
    !
    ip dhcp pool UserPool
    import all
    network 192.168.88.0 255.255.255.0
    default-router 192.168.88.1
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    subscriber templating
    !
    !
    multilink bundle-name authenticated
    !
    !
    !
    crypto pki trustpoint TP-self-signed-1953940975
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1953940975
    revocation-check none
    rsakeypair TP-self-signed-xxxxxxx
    !
    crypto pki trustpoint SLA-TrustPoint
    enrollment pkcs12
    revocation-check crl
    !
    !
    crypto pki certificate chain TP-self-signed-xxxxxxx
    certificate self-signed 01
    30820330 …
    quit
    crypto pki certificate chain SLA-TrustPoint
    certificate ca 01
    30820321 …
    quit
    !
    license udi pid C1111-4PLTEEA sn XXXXXXX
    license smart enable
    license smart conversion automatic
    !
    diagnostic bootup level minimal
    !
    spanning-tree extend system-id
    !
    !
    username SolverAdmin privilege 15 secret 5 XXXXXXX
    !
    redundancy
    mode none
    !
    controller Cellular 0/2/0
    lte sim data-profile 1 attach-profile 1 slot 0
    lte modem link-recovery rssi onset-threshold -110
    lte modem link-recovery monitor-timer 20
    lte modem link-recovery wait-timer 10
    lte modem link-recovery debounce-count 6
    !
    !
    vlan internal allocation policy ascending
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0/0
    no ip address
    negotiation auto
    !
    interface GigabitEthernet0/0/1
    description SolverRTR WAN port
    no ip address
    ip mtu 1452
    ip access-group 1 out
    ip tcp adjust-mss 1412
    negotiation auto
    ipv6 enable
    ipv6 nd autoconfig default-route
    ipv6 dhcp client request vendor
    pppoe enable group global
    pppoe-client dial-pool-number 1
    !
    interface GigabitEthernet0/1/0
    description LANinterface
    switchport access vlan 88
    !
    interface GigabitEthernet0/1/1
    !
    interface GigabitEthernet0/1/2
    !
    interface GigabitEthernet0/1/3
    !
    interface Cellular0/2/0
    description Secondary_
    ip address negotiated
    ip access-group 1 out
    ipv6 enable
    !
    interface Cellular0/2/1
    no ip address
    !
    interface Vlan1
    no ip address
    !
    interface Vlan88
    ip address 192.168.88.1 255.255.255.0
    ip nat inside
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1412
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent
    dialer-group 1
    ppp mtu adaptive
    ppp authentication pap callin
    ppp chap hostname ptXXXXXX@SKYNET
    ppp chap password 0 XXXXXX
    ppp pap sent-username ptXXXXXX@SKYNET password 0 XXXXXX
    ppp ipcp dns request
    !
    ip local policy route-map track-primary-intf
    ip nat inside source route-map track-primary-if interface Dialer1 overload
    ip nat inside source list 1 interface GigabitEthernet0/0/1 overload
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip dns server
    ip route 0.0.0.0 0.0.0.0 Dialer1 track 1
    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1 track 1
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 0.0.0.0 0.0.0.0 Cellular0/2/0 253
    !
    !
    access-list 1 permit 192.168.88.0 0.0.0.255
    access-list 102 permit icmp any host 8.8.8.8
    !
    !
    route-map track-primary-if permit 1
    match ip address 197
    set interface Dialer1 GigabitEthernet0/0/1
    !
    route-map track-primary-intf permit 10
    match ip address 102
    set interface GigabitEthernet0/0/1
    !
    !
    !
    control-plane
    !
    !
    line con 0
    exec-timeout 0 0
    transport input none
    stopbits 1
    line vty 0 4
    login
    !
    !
    !
    !
    !
    !
    !
    pnp profile pnp_cco_profile
    transport https ipv4 18.205.167.7 port 443
    end

Leave a Reply