MVPN Profile-0 (Draft Rosen) Config on GNS3

Hi Friends,

This is going to be a short and crisp article on MVPN Profile 0.  I had some posts about L2VPN and L3VPN. In those posts I have discussed about unicast between the sites over MPLS ISP backbone. You can check my L2VPN and L3VPN posts here.

L2VPN

L3VPN

In this post I am going to discuss about multicast between the sites over bgp mpls ISP backbone. For this lab you need to have L3VPN configured between the sites. My topology is pretty simple, as I said that I will be doing this on GNS3 hence here is the GNS3 topology.

Topology

 

Configurations:

PE1 Configuration :

!
vrf definition C1
rd 100:1
route-target export 100:1
route-target import 100:2
!
address-family ipv4
mdt default 232.1.1.10
mdt data 232.1.2.0 0.0.0.255 threshold 10
exit-address-family
!
ip multicast-routing distributed
ip multicast-routing vrf C1 distributed
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
ip router isis CORE
!
interface Loopback2
vrf forwarding C1
ip address 11.11.11.11 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet1
ip address 10.10.10.1 255.255.255.252
ip pim sparse-mode
ip router isis CORE
mpls ip

!
router isis CORE
net 49.0001.0000.0000.00
metric-style narrow
!
router bgp 100
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 3.3.3.3 next-hop-self
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf C1
redistribute connected
exit-address-family
!
ip pim ssm default
ip pim vrf C1 rp-address 44.44.44.44
!
mpls ldp router-id Loopback1

 

P1 configurations :

 

!
ip multicast-routing 
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip router isis CORE
ip pim sparse-mode
!
interface GigabitEthernet0/0
ip address 10.10.10.2 255.255.255.252
ip router isis CORE
ip pim sparse-mode
mpls ip
!
interface GigabitEthernet0/1
ip address 10.10.10.5 255.255.255.252
ip router isis CORE
ip pim sparse-mode
mpls ip
!
router isis CORE
net 49.0002.0000.0000.00
!
ip pim ssm default
! 
mpls ldp router-id Loopback1

Route-reflector configuration :

 

!
ip multicast-routing 
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
ip router isis CORE
ip pim sparse-mode
!
interface GigabitEthernet0/0
ip address 10.10.10.6 255.255.255.252
ip router isis CORE
ip pim sparse-mode
mpls ip
!
interface GigabitEthernet0/1
ip address 10.10.10.9 255.255.255.252
ip router isis CORE
ip pim sparse-mode
mpls ip
!
router isis CORE
net 49.0003.0000.0000.00
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 1.1.1.1 route-reflector-client
neighbor 1.1.1.1 next-hop-self
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
neighbor 4.4.4.4 route-reflector-client
neighbor 4.4.4.4 next-hop-self
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neighbor 1.1.1.1 route-reflector-client
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
neighbor 4.4.4.4 route-reflector-client
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 route-reflector-client
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 route-reflector-client
exit-address-family
!
ip pim ssm default
!
mpls ldp router-id Loopback1
!

 

PE2 Configurations:

 

vrf definition C1
rd 100:2
route-target export 100:2
route-target import 100:1
!
address-family ipv4
mdt default 232.1.1.10
mdt data 232.1.2.0 0.0.0.255 threshold 10
exit-address-family
!
ip multicast-routing distributed
ip multicast-routing vrf C1 distributed
! 
interface Loopback1
ip address 4.4.4.4 255.255.255.255
ip pim sparse-mode
ip router isis CORE
!
interface Loopback2
vrf forwarding C1
ip address 44.44.44.44 255.255.255.255
ip pim sparse-mode
ip igmp join-group 239.248.80.80
!
interface GigabitEthernet1
ip address 10.10.10.10 255.255.255.252
ip pim sparse-mode
ip router isis CORE
negotiation auto
mpls ip
no mop enabled
no mop sysid
!
router isis CORE
net 49.0004.0000.0000.00
metric-style narrow
!
router bgp 100
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 3.3.3.3 next-hop-self
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf C1
redistribute connected
exit-address-family
!
ip pim vrf C1 rp-address 44.44.44.44
!
mpls ldp router-id Loopback1

 

Verification :

Router#sh bgp ipv4 mdt all 4.4.4.4/32 
BGP routing table entry for 100:2:4.4.4.4/32 version 3
Paths: (1 available, best #1, table IPv4-MDT-BGP-Table)
Advertised to update-groups:
1 
Refresh Epoch 1
Local
0.0.0.0 from 0.0.0.0 (4.4.4.4)
Origin incomplete, localpref 100, valid, sourced, local, best,
MDT group address: 232.1.1.10

rx pathid: 0, tx pathid: 0x0

Router#ping vrf C1 239.248.80.80 rep 2
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 239.248.80.80, timeout is 2 seconds:
.
Reply to request 1 from 44.44.44.44, 24 ms

Router#sh ip mroute vrf C1
<OUTPUT SNIP>

(*, 239.248.80.80), 00:00:11/stopped, RP 44.44.44.44, flags: SPF
  Incoming interface: Tunnel1, RPF nbr 4.4.4.4
  Outgoing interface list: Null

(11.11.11.11, 239.248.80.80), 00:00:11/00:02:50, flags: FT
  Incoming interface: Loopback2, RPF nbr 0.0.0.0, Registering
  Outgoing interface list:
    Tunnel1, Forward/Sparse, 00:00:09/00:03:20

 

Packet capture :

You can see in below capture that why we call this multicast in multicast.

MOM

 

In my upcoming articles I am going to cover other MVPN profiles.

Thank you.


Leave a Reply