MPLS Basic configuration and MPLS QOS

Cisco MPLS basic configuration
MPLS

We know that for most of the protocols router does not change anything in the IP header unless we have specifically configured the IP header to be changed for example NAT, QOS markings etc.

In this and few upcoming posts we will specifically look for packet marking when the  IP packet gets translated into MPLS labels. We will look into the fact that what exactly happens with the QOS markings when labels are imposed on to the packet.

For internal routing I am using EIGRP in my setup , we can have any routing protocol to achieve the reachability in the network. MPLS uses FIB derived from routing protocols to derive LFIB(Label forwarding information base) which is used for the eventual label switching.

In the above network diag we have three routers running MPLS. Following are the configurations:

R1:

mpls label range 100 200
mpls label protocol ldp

!

interface Loopback1
 ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet1/0
 ip address 13.13.13.1 255.255.255.252
 mpls ip

!

router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 13.13.13.0 0.0.0.3
 auto-summary

R2:

mpls label range 300 400
mpls label protocol ldp

!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255

!
interface FastEthernet1/0
 ip address 13.13.13.2 255.255.255.252
 mpls ip
!
interface FastEthernet1/1
 ip address 14.14.14.1 255.255.255.252
 mpls ip

!
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 13.13.13.0 0.0.0.3
 network 14.14.14.1 0.0.0.0
 no auto-summary

R3:

mpls label range 500 600
mpls label protocol ldp
!

interface Loopback1
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
 ip address 14.14.14.2 255.255.255.252
 mpls ip

!

router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 14.14.14.2 0.0.0.0
 no auto-summary

 

verification :

R1#show mpls forwarding-table
Local   Outgoing     Prefix               Bytes Label   Outgoing   Next Hop
Label   Label        or  VC orTunnel Id   Switched      interface
16     Pop Label   14.14.14.0/30             0           Fa1/0     13.13.13.2
100    Pop Label   2.2.2.2/32                0           Fa1/0     13.13.13.2
101    300         3.3.3.3/32                0           Fa1/0    13.13.13.2

 

R2#show mpls forwarding-table
Local    Outgoing     Prefix Bytes       Label      Outgoing   Next Hop
Label     Label      or VC or Tunnel Id  Switched   interface
16         Pop Label  1.0.0.0/8          570         Fa1/0     13.13.13.1
300        Pop Label  3.3.3.3/32         2850        Fa1/1     14.14.14.2
R3#show mpls forwarding-table
Local   Outgoing    Prefix Bytes       Label    Outgoing    Next Hop
Label   Label      or VC or Tunnel Id  Switched  interface
500      16        1.0.0.0/8            0      Fa1/0      14.14.14.1
501      Pop Label  2.2.2.2/32          0      Fa1/0      14.14.14.1
502      Pop Label  13.13.13.0/30       0       Fa1/0     14.14.14.1

 

Here we see that mpls is working fine, you can verify the same when you see “label switched ” packet counts increasing in the above command. You can also verify the same with traceroute , it will tell you the imposed label as well as the EXP Bit which I will talk about in my next post.

R1#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3

1 13.13.13.2 [MPLS: Label 300 Exp 0] 100 msec 12 msec 24 msec
 2 14.14.14.2 36 msec 96 msec 96 msec

 

I will not make this post boring by putting QOS details. Please see my next post for MPLS QOS details…Stay tuned!!

Advertisements

One thought on “MPLS Basic configuration and MPLS QOS

Leave a Reply