Cisco ISIS GNS3 lab tasks and few other details ….

ISIS GNS3
GNS3 topolgy

 

I have this topology along with 6 tasks published in my previous blogs regarding ISIS. Check here , ISIS Blog 1, ISIS Blog 2, ISIS Blog 3 .

Now when I have covered the basics of ISIS I feel the need to explain the lab topology and tasks…below is the same ..have fun!!

Task 1: Configure ISIS in multi-access area type between R1,R2 and R3

Task 2: Configure ISIS over point to point network between R1 and R4

Task 3: Configure R2 and R3 as the L1 ISIS router

Task 4: Check the routing tables of R2 and R3 …how it is different from R1’s routing table.

Task 5: Take packet capture on any link between R1,R2 and R3 and identify below:

  •  Who is DIS in the network?
  • How many types of CSNP sent by DIS when all the routers are of type L1-L2
  • How many types of CSNP sent by DIS when all R2 and R3 routers are of type L1 only.
  • Reset the adjacency on ISIS DIS and see what kind of packets you see after hello exchange.

Task 6: Take a packet capture on the link between R1 and R4…identify the differences between multi-access and point to point networks.

 

Configuration:

In This network Router R1,R2 and R3 are in a single area 49.0001 and R4 is in different area 49.0002 connected with 49.0001 via router R1. In below configuration you would see few of the loopback created, please note that the loopbacks are just for the advertisement sake and it is absolutely not mandatory to have one.

 

R1#

!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
ip router isis
!
interface FastEthernet1/0
ip address 20.20.20.2 255.255.255.252
ip router isis
!

router isis
net 49.0001.0000.0000.0001.00
!

R2#

!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
ip router isis
!

router isis
net 49.0001.0000.0000.0002.00
is-type level-1
!

R3#

!
interface FastEthernet0/0
ip address 10.10.10.3 255.255.255.0
ip router isis
!
router isis
net 49.0001.0000.0000.0003.00
is-type level-1
!

R4 #

interface Loopback1
ip address 4.4.4.4 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 20.20.20.1 255.255.255.252
ip router isis
!
router isis
net 49.0002.0000.0000.0004.00

Verification:

R1#show isis neighbors
System Id     Type Interface   IP Address     State Holdtime Circuit Id

R3             L1   Fa0/0       10.10.10.3     UP   7       R3.01

R2             L1   Fa0/0       10.10.10.2     UP   27       R3.01

R4             L2   Fa1/0       20.20.20.1     UP   8       R4.01

R1#show clns neighbors

System Id     Interface   SNPA               State Holdtime Type Protocol

R3             Fa0/0       ca03.4628.0000     Up     9         L1   IS-IS

R2             Fa0/0       ca02.5210.0000     Up     20       L1   IS-IS

R4             Fa1/0      ca04.0e50.0000     Up     8         L2   IS-IS

R1#show isis database

IS-IS Level-1 Link State Database:

LSPID                 LSP Seq Num LSP Checksum LSP Holdtime     ATT/P/OL

R1.00-00           * 0x00000162   0x650F        1069             1/0/0

R2.00-00             0x0000009B   0x8823       430               0/0/0

R3.00-00             0x000009C2   0x22DD       1134             0/0/0

R3.01-00             0x000009BD   0xE01C       900               0/0/0

IS-IS Level-2 Link State Database:

LSPID                 LSP Seq Num LSP Checksum LSP Holdtime     ATT/P/OL

R1.00-00           * 0x00000163   0xB21E       439               0/0/0

R4.00-00             0x00000070   0x5D46       734               0/0/0

R4.01-00             0x0000006C   0x4327       469               0/0/0

R1#show isis database R2.00-00 detail

 IS-IS Level-1 LSP R2.00-00

LSPID                 LSP Seq Num         LSP Checksum LSP Holdtime     ATT/P/OL

R2.00-00             0x0000009C                         0x8624       1154             0/0/0

Area Address: 49.0001

NLPID:       0xCC

Hostname: R2

IP Address:   2.2.2.2

Metric: 10         IP 10.10.10.0 255.255.255.0

Metric: 10         IP 2.2.2.2 255.255.255.255

Metric: 10         IS R3.01

R1#show isis topology

IS-IS paths to level-1 routers

System Id           Metric     Next-Hop             Interface   SNPA

R1                   --

R2                   10         R2                  Fa0/0       ca02.5210.0000

R3                   10         R3                   Fa0/0       ca03.4628.0000

IS-IS paths to level-2 routers

System Id           Metric     Next-Hop             Interface   SNPA

R1                   --

R4                  10         R4                   Fa1/0       ca04.0e50.0000

R1#show ip route

2.0.0.0/32 is subnetted, 1 subnets

i L1   2.2.2.2 [115/20] via 10.10.10.2, FastEthernet0/0

4.0.0.0/32 is subnetted, 1 subnets

i L2   4.4.4.4 [115/20] via 20.20.20.1, FastEthernet1/0

20.0.0.0/30 is subnetted, 1 subnets

C       20.20.20.0 is directly connected, FastEthernet1/0

routers      10.0.0.0/24 is subnetted, 1 subnets

C       10.10.10.0 is directly connected, FastEthernet0/0

Similarly you may run these commands on other routers .

I would like to show you the output of routing table on a pure L1 router. As you may see below the pure L1 routes does not need to have all the routes from different area rather it has a default gateway pointing towards the L2 router which connects to other areas of network. If you remember we can get this kind of feature in ospf by totally stubby area type configuration …and here in ISIS its by default.

 

R2#show ip route

Gateway of last resort is 10.10.10.1 to network 0.0.0.0

2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback1

20.0.0.0/30 is subnetted, 1 subnets

i L1   20.20.20.0 [115/20] via 10.10.10.1, FastEthernet0/0

10.0.0.0/24 is subnetted, 1 subnets

C     10.10.10.0 is directly connected, FastEthernet0/0

i*L1 0.0.0.0/0 [115/10] via 10.10.10.1, FastEthernet0/0

 

Answers for the lab tasks questions:

 Task 1: Configure ISIS in multi-access area type between R1,R2 and R3.

Answer: All the configuration pasted above.

Task 2: Configure ISIS over point to point network between R1 and R4.

Answer: Configuration pasted above , there is no such difference in configuration but the operational difference is considerable. Like no DIS in p2p, no periodic CSNP p2p etc

Task 3: Configure R2 and R3 as the L1 ISIS router.

Answer: Config pasted above.

Task 4: Check the routing tables of R2 and R3 …how it is different from R1’s routing table.

Answer: Explained above, the border router has all the routes(L1 and L2 or inter and inter-area) but the internal routers R2 and R3 does only have the default route towards R1 to reach outside the area.

Task 5: Take packet capture on any link between R1,R2 and R3 and identify below.

  •  Who is DIS in the network?
  •  How many types of CSNP sent by DIS when all the routers are of type L1-L2
  • How many types of CSNP sent by DIS when all R2 and R3 routers are of type L1 only
  • Reset the adjacency on ISIS DIS and see what kind of packets you see after hello exchange.

Answer: Please refer my last post   for packet captures. As whole DIS information would be in hello packet, there would be two CSNPs (L1 and L2 CSNP) if the link is L1 and L2 type. Once you reset the adjacency the whole routing table would be exchanged …you would see HELLO followed by CSNP and then LSPs exchanged on the link.

Task 6: Take a packet capture on the link between R1 and R4…identify the differences between multi-access and point to point networks.

Answer: The main goal for this task is to understand the triggered update propagation in the multi-access and point to point network. In p2p network when any failure happens the data would be passed to the other peer with the help of LSP and that LSP would be relayed to other p2p routers. On receiving LSP the router would  use PSNP to ack the update.

On the other hand any new prefix added in ISIS would be propagated by LSP to everybody in the multi-access network and done by the router where the prefix is created/added/learnt. Same happens when any failure occurs in the routing domain.

Extra Tip: CSNP packet contains the system ID of neighbor and the latest LSP received from that node. On receiving the CSNP all devices compare the sequence numbers they have …if the sequence numbers doesn’t match then the device would request for the prefix via PSNP.

Thank You for reading  Please leave your questions and suggestions in comment section….happy learning!!


One thought on “Cisco ISIS GNS3 lab tasks and few other details ….

Leave a Reply